SurePrep Scheduled Maintenance - Monitoring
Resolved
Since mitigation measures were put into place, SurePrep teams have continued to observe overall stability in SPbinder processing and consider the issue resolved. If you encounter any instances of binders taking longer than usual to access, please contact SurePrep Support for assistance.

It the system status changes, or further queues develop, updates will be posted here: https://taxprofessionals-status.hostedtax.thomsonreuters.com.
Posted Nov 27, 2024 - 03:52 EST
Monitoring
The scheduled maintenance from November 22nd has completed, however we are continuing to monitor our SurePrep services today as we are seeing some internal service degradation. If you are experiencing any issues, please contact our Support team.
Posted Nov 25, 2024 - 11:56 EST
This incident affected: SurePrep SPbinder.