SurePrep TaxCaddy "Oops" Message
Resolved
The TaxCaddy "Oops" issue has been resolved. If the status changes, updates will posted here: https://taxprofessionals-status.hostedtax.thomsonreuters.com/
Posted Jan 13, 2025 - 12:13 EST
Monitoring
We have received reports from some customers encountering an “Oops” message while navigating within the TaxCaddy administrative tabs. The issue has been addressed. SurePrep engineers are monitoring the situation. If the system status changes, updates will be posted here: https://taxprofessionals-status.hostedtax.thomsonreuters.com
Posted Jan 13, 2025 - 11:05 EST
This incident affected: SurePrep TaxCaddy (TaxCaddy Dashboard).