SurePrep - TaxCaddy Slowness

Resolved

We have tested and implemented a fix that restored all services in TaxCaddy. In addition, no new customer contacts have been received that are associated with this issue. Given this, we will move this incident to resolved status.
Posted Mar 12, 2025 - 12:39 EDT

Investigating

Based on our internal monitoring, we are aware that some customers are experiencing slowness in TaxCaddy. We are currently working to resolve and will provide an update as soon as we have more information.
Posted Mar 12, 2025 - 10:47 EDT
This incident affected: SurePrep TaxCaddy (TaxCaddy Dashboard).