Virtual Office CS / SaaS - US - Degraded Performance
Resolved
This incident has been resolved.
Posted May 12, 2022 - 19:30 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 12, 2022 - 16:23 UTC
Investigating
We have received reports of slowness in Virtual Office CS and SaaS applications for a small subset of Users. We're investigating and monitoring the situation. We'll update the status page and send an update to subscribers as soon as we have more information.
Posted May 12, 2022 - 15:43 UTC
This incident affected: Virtual Office CS / SaaS.