www.confirmation.com
Resolved
Confirmation.com is currently working for all customers.
Posted May 11, 2022 - 13:04 EDT
Update
The issues has been resolved.
Posted May 11, 2022 - 13:03 EDT
Update
We are continuing to investigate this issue.
Posted May 09, 2022 - 14:28 EDT
Investigating
We are currently investigating a issue where users are getting kicked out when signing in.
Posted May 09, 2022 - 14:27 EDT
This incident affected: Confirmation.com.