SurePrep - Slowness within SPbinder and delays exporting data to tax software

Resolved

Our metrics and internal testing continue to indicate performance within SurePrep remains in a healthy state. In addition, no new customer contacts have been received associated with this issue. Given this, we will move this incident to resolved status.
Posted Mar 18, 2025 - 16:17 EDT

Monitoring

We have implemented a fix to resolve the delays or slowness when accessing SurePrep binders, exporting data to their tax software, and navigating through Verification wizards. With that fix, we have observed an improvement in system performance. We will continue to closely monitor our internal metrics and customer contacts to ensure the issue is fully resolved.
Posted Mar 18, 2025 - 10:51 EDT

Investigating

Some customers are experiencing delays or slowness when accessing SurePrep binders, exporting data to their tax software, and navigating through Verification wizards. Users may encounter errors during these processes. SurePrep engineers are currently investigating the issue. Incident updates will be posted here: https://taxprofessionals-status.hostedtax.thomsonreuters.com/
Posted Mar 18, 2025 - 10:37 EDT
This incident affected: SurePrep Integrations (GoFileRoom Integration) and SurePrep SPbinder, SurePrep 1040SCAN Review Wizard.