CoCounsel Invitation Email Issue

Resolved

We have successfully resolved the email delivery issue that was affecting invitation emails. Going forward, login and invitation emails will be sent from our CoCounsel email address (no-reply@accounting.cocounsel.thomsonreuters.com).
Posted Sep 10, 2025 - 18:25 EDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 10, 2025 - 14:42 EDT

Identified

Reports are confirmed that Invitation emails from CoCounsel have been impacted due to an issue from an email provider. A resolution is estimated by end of the day as CoCounsel Development teams are currently working on resolving this issue.
Posted Sep 10, 2025 - 14:05 EDT
This incident affected: CoCounsel for Tax, Audit & Accounting (Core - Tax, Audit & Accounting).