Tax and Accounting Professionals Learning Center - US - Degraded Performance
Resolved
Tax and Accounting Professionals Learning Center is currently working at expected speeds.
Posted Jul 28, 2020 - 14:25 UTC
Investigating
We have received reports of slowness in Tax and Accounting Professionals Learning Center. We're investigating and monitoring the situation. We'll update the status page and send an update to subscribers as soon as we have more information.
Posted Jul 28, 2020 - 14:06 UTC
This incident affected: Tax and Accounting Professionals Learning Center.