Web Builder CS - US - Service Disruption
Resolved
Web Builder CS is currently working for all customers.
Posted Aug 01, 2020 - 11:12 UTC
Investigating
We have received reports that Web Builder CS is unavailable. We're investigating and monitoring the situation. We'll update the status page and send an update to subscribers as soon as we have more information.
Posted Aug 01, 2020 - 11:06 UTC
This incident affected: Web Builder CS.