Errors while accessing or viewing documents in Engagement Manager and GoFileRoom

Resolved

This incident has been resolved.
Posted Jul 22, 2025 - 15:31 EDT

Monitoring

We have tested and implemented a fix that restored all services in GoFileRoom and Engagement Manager. We are closely monitoring the changes and customer contacts to ensure the issue has been fully remediated. We will continue to provide you updates on the status of the environment. If you continue to experience issues, please clear cache and cookies in your browser then try again.
Posted Jul 22, 2025 - 12:44 EDT

Identified

Based on our internal monitoring, we are aware that some customers are experiencing errors while accessing or viewing documents in Engagement Manager and GoFileRoom. We have determined the issue causing these errors. We are working with the highest priority to resolve and restore the applications. We will provide another update as soon as we have more information.
Posted Jul 22, 2025 - 12:20 EDT
This incident affected: Engagement Manager and GoFileRoom.