Legal Ed Center - US - Service Disruption
Resolved
Checkpoint Learning - Legal Ed Center is currently unavailable for all customers. We're sorry for the disruption and our development teams are working to fix this as soon as possible. We'll send an update when we have more information.
Posted Jun 10, 2021 - 07:34 UTC
Investigating
We have received reports that Checkpoint Learning - Legal Ed Center is unavailable. We're investigating and monitoring the situation. We'll update the status page and send an update to subscribers as soon as we have more information.
Posted Jun 10, 2021 - 07:33 UTC
This incident affected: Legal Ed Center.