Legal Ed Center - US - Degraded Performance
Resolved
Checkpoint Learning - Legal Ed Center is currently working at expected speeds.
Posted Jul 28, 2020 - 10:22 UTC
Investigating
We have received reports of slowness in Checkpoint Learning - Legal Ed Center. We're investigating and monitoring the situation. We'll update the status page and send an update to subscribers as soon as we have more information.
Posted Jul 28, 2020 - 10:21 UTC
This incident affected: Legal Ed Center.