Our metrics and internal testing continue to indicate all applications remain in a healthy state. In addition, no new customer contacts have been received that are associated with this issue. Given this, we will move this incident to resolved status.
Posted Oct 20, 2025 - 20:01 EDT
Update
While our third-party cloud service provider is working on restoration, some of our applications are still being impacted and some users will be unable to login. We continue to monitor, and we will provide updates as new information becomes available.
Posted Oct 20, 2025 - 15:21 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 08:36 EDT
Monitoring
Based on our monitoring checks and internal testing, we are aware that some users are experiencing issues when accessing certain Thomson Reuters solutions and services. We have determined these issues are being caused by a widespread third-party cloud service provider - affecting multiple customers, including us. Following escalation of the issues with the vendor, we are seeing recovery across our products, applications, and services, with access to several now fully restored. We continue to monitor, and we will provide updates as new information becomes available.
Posted Oct 20, 2025 - 07:20 EDT
This incident affected: Checkpoint Research, Confirmation.com, CS Connect/Electronic Filing, CS Professional Suite Local Login, Engagement Manager, GoFileRoom, Guided Assurance, NetClient CS, NetFirm CS, Onvio Firm Management, Virtual Office CS / SaaS, and SurePrep FileRoom.