Virtual Office CS/Software as a Service - US

Resolved

Our metrics and internal testing continue to indicate the ability to login to Virtual Office and Software as a Service remain in a healthy state. In addition, no new customer contacts have been received that are associated with this issue. Given this, we will move this incident to resolved status.
Posted Sep 16, 2025 - 17:02 EDT

Monitoring

We have restored the ability to login to Virtual Office CS or Software as a Service. We will continue to closely monitor our internal metrics and customer contacts to ensure the issue is fully resolved. We will continue to monitor the environment and will provide another update at end of business day.
Posted Sep 16, 2025 - 12:59 EDT

Identified

While NetFirm CS and NetClient CS logins are now succeeding, some users may still be experiencing slowness with launching Virtual Office CS and other Software as a Service applications.

We have identified the root cause and our teams are working with the highest priority to fully restore performance. We’ll provide another update as soon as we have more information.
Posted Sep 16, 2025 - 12:15 EDT

Investigating

Based on our internal monitoring, we are aware that some customers cannot login to Virtual Office CS, Software as a Service, NetFirm CS, or NetClient CS and are receiving an "Unknown Login Failure" message. We are currently working to restore services and will provide an update as soon as we have more information.
Posted Sep 16, 2025 - 10:52 EDT
This incident affected: Virtual Office CS / SaaS.