Customer Support and Technical Support - Phone System

Resolved

Based on restoration from a third-party cloud service provider, we are now successfully receiving calls via our phone system. We appreciate your patience as we work through our backlog.
Posted Oct 20, 2025 - 16:17 EDT

Identified

Due to a widespread issue with a third-party cloud service provider, we are experiencing technical difficulties with our phone system when calling our Technical Support or Customer Support teams. During this time, you may experience longer than normal wait times. Please utilize other channels to contact Support until this is fully resolved. We will provide updates as new information becomes available.
Posted Oct 20, 2025 - 10:11 EDT
This incident affected: Customer Support.