AdvanceFlow - US - Partial Service Disruption - Update
Resolved
AdvanceFlow is currently working for all customers.
Posted Sep 12, 2019 - 16:11 EDT
Identified
AdvanceFlow is currently experiencing issues displaying documents. We're sorry for the disruption and our development teams are working to fix this as soon as possible. We'll send an update when we have more information.
Posted Sep 12, 2019 - 14:47 EDT
This incident affected: AdvanceFlow and Checkpoint Engage with AdvanceFlow.