GoSystem Tax RS - US - Degraded Performance
Resolved
GoSystem Tax RS is currently working for all customers.
Posted about 1 month ago. Aug 12, 2019 - 10:05 UTC
Investigating
We have received reports that GoSystem Tax RS is running slowly. We're investigating and monitoring the situation. We'll update the status page and send an update to subscribers as soon as we have more information.
Posted about 1 month ago. Aug 12, 2019 - 10:04 UTC
This incident affected: GoSystem Tax RS.