Virtual Office CS / SaaS - US - Degraded Performance
Resolved
Virtual Office CS and Software as a Service performance has been restored for customers who were impacted. We apologize for any disruption and inconvenience.
Posted Mar 06, 2023 - 16:09 EST
Identified
We have received reports that some customers are unable to access Virtual Office CS and SaaS applications. We're investigating and we'll update the status page and send an update to subscribers as soon as we have more information.
Posted Mar 06, 2023 - 15:46 EST
This incident affected: Virtual Office CS / SaaS.