Confirmation - Secure.Rivio.Com - US - Service Disruption
Resolved
secure.rivio.com is currently working for all customers.
Posted Mar 31, 2021 - 08:58 UTC
Investigating
We have received reports that secure.rivio.com powered by Confirmation is unavailable. We're investigating and monitoring the situation. We'll update the status page and send an update to subscribers as soon as we have more information.
Posted Mar 31, 2021 - 05:35 UTC
This incident affected: Confirmation.com - Rivio.