NetFirm CS - US - Service Disruption

Resolved

Our metrics and internal testing continue to indicate sending or receiving documents in NetFirm CS remain in a healthy state. In addition, no new customer contacts have been received that are associated with this issue. We are moving this to a resolved status.
Posted Jul 28, 2025 - 15:21 EDT

Monitoring

We have resolved the ability to download files that were uploaded between Saturday, July 26, 10:50 PM ET and Monday, July 28, 10:17 AM ET and all documents can be sent and received in NetFirm CS. We will continue to monitor our internal metrics and customer contacts to confirm full resolution.
Posted Jul 28, 2025 - 12:36 EDT

Update

We have resolved the issue with users not being able to send or receive documents in NetFirm CS. At this time, any new uploads should be successful as well as any downloads of files that were uploaded prior to Saturday, July 26, 10:50 PM ET. We are still working on downloads of files that were uploaded between Saturday, July 26, 10:50 PM ET and Monday, July 28, 10:17 AM ET.
Posted Jul 28, 2025 - 10:49 EDT

Identified

Based on our internal monitoring, we are aware that some users are not able to send or receive documents in NetFirm CS, including File Exchange, Document Presentation, eSignature, and Remote Payroll. We are currently working to restore services and will provide an update as soon as we have more information.
Posted Jul 28, 2025 - 10:12 EDT
This incident affected: NetClient CS.