SurePrep - SPbinder Slowness

Resolved

Our metrics and internal testing continue to indicate opening and working within SurePrep Binders remain in a healthy state. In addition, no new customer contacts have been received associated with this issue. Given this, we will move this incident to resolved status.
Posted Mar 13, 2025 - 18:56 EDT

Monitoring

We have implemented a fix to resolve the slowness encountered when opening and working within SurePrep Binders, and have observed an improvement in system performance. We will continue to closely monitor our internal metrics and customer contacts to ensure the issue is fully resolved.
Posted Mar 13, 2025 - 18:12 EDT

Investigating

Based on our internal monitoring, we are aware that some customers may be experiencing slowness when opening and working within SurePrep binders. We are currently working to resolve and will provide an update as soon as we have more information.
Posted Mar 13, 2025 - 17:17 EDT
This incident affected: SurePrep SPbinder and SurePrep 1040SCAN Review Wizard.