Our metrics and internal testing continue to indicate performance within SurePrep remains in a healthy state. In addition, no new customer contacts have been received associated with this issue. Given this, we will move this incident to resolved status.
Posted 15 days ago. Mar 17, 2025 - 19:00 EDT
Monitoring
We have implemented a fix to resolve the slowness encountered with SPbinder processing, exporting data and navigating through Verification wizards. With that fix, we have observed an improvement in system performance. We will continue to closely monitor our internal metrics and customer contacts to ensure the issue is fully resolved.
Posted 15 days ago. Mar 17, 2025 - 16:25 EDT
Identified
We have identified and are working on implementing a fix to resolve the slowness issues within SurePrep. We will provide another update as soon as we have more information.
Posted 15 days ago. Mar 17, 2025 - 13:43 EDT
Investigating
Some customers are experiencing delays with SPbinder processing, exporting data from their tax software, and navigating through Verification wizards. Users may encounter errors during these processes. SurePrep engineers are currently investigating the issue. Incident updates will be posted here: https://taxprofessionals-status.hostedtax.thomsonreuters.com/
Posted 15 days ago. Mar 17, 2025 - 11:46 EDT
This incident affected: SurePrep SPbinder and SurePrep 1040SCAN Review Wizard.