Optimus - US - Degraded Performance
Resolved
Optimus is currently working at expected speeds.
Posted Jul 09, 2021 - 03:33 UTC
Investigating
We have received reports of slowness in Optimus. We're investigating and monitoring the situation. We'll update the status page and send an update to subscribers as soon as we have more information.
Posted Jul 09, 2021 - 03:32 UTC
This incident affected: Optimus.