SurePrep - Connectivity Issues - Binders with "In Verification" Status

Resolved

Our metrics and internal testing continue to indicate the connectivity issues primarily with opening binders with a status of "In Verification" remain in a healthy state. In addition, no new customer contacts have been received associated with this issue. Given this, we will move this incident to resolved status.
Posted Mar 06, 2025 - 19:36 EST

Update

SurePrep teams are continuing to monitor the system status following the fix implemented earlier today for the connectivity issues in relation primarily to opening binders with a status of "In Verification." We will continue to closely monitor our internal metrics and customer contacts to ensure the issue is fully resolved.
Posted Mar 06, 2025 - 16:44 EST

Monitoring

We have implemented a fix to resolve the SurePrep-related connectivity issues. We will continue to closely monitor our internal metrics and customer contacts to ensure the issue is fully resolved.
Posted Mar 06, 2025 - 14:50 EST

Investigating

We have received reports that some customers are experiencing connectivity issues within SurePrep. SurePrep engineers are investigating at this time. We will provide an update when we have further information.
Posted Mar 06, 2025 - 12:33 EST
This incident affected: SurePrep SPbinder and SurePrep 1040SCAN Review Wizard.