Our metrics and internal testing continue to indicate SafeSend Returns remain in a healthy state. In addition, no new customer contacts have been received that are associated with this issue. Given this, we will move this incident to resolved status.
Posted Sep 15, 2026 - 16:53 EDT
Monitoring
We are aware of a brief disruption affecting the SafeSend Returns client experience. The issue has been resolved, and the login functionality is restored. We will continue to monitor our internal metrics and customer contacts to confirm full resolution.
Posted Sep 15, 2026 - 12:02 EDT
Investigating
We are aware of a service interruption affecting the SafeSend Returns client experience. Taxpayers are currently unable to login or access SafeSend Returns. We are actively investigating the cause and appreciate your patience on this busy tax deadline day. We will share updates as we learn more.
Posted Sep 15, 2026 - 11:32 EDT
This incident affected: SafeSend (SafeSend Returns).