ONESOURCE University - US - Service Disruption
Resolved
ONESOURCE University is currently working for all customers and clients.
Posted Jul 28, 2020 - 09:44 UTC
Investigating
We have received reports that ONESOURCE University is unavailable. We're investigating and monitoring the situation. We'll update the status page and send an update to subscribers as soon as we have more information.
Posted Jul 28, 2020 - 09:43 UTC
This incident affected: ONESOURCE University.