Ufile Online - CA - Service Disruption
Resolved
Ufile Online is currently working for all customers.
Posted Nov 10, 2022 - 13:59 EST
Investigating
We have received reports that Ufile Online is unavailable. We're investigating and monitoring the situation. We'll update the status page and send an update to subscribers as soon as we have more information.
Posted Nov 10, 2022 - 13:35 EST
This incident affected: Ufile Online.