GoFileRoom - US - Degraded Performance
Resolved
GoFileRoom is currently working at expected speeds.
Posted about 1 month ago. Aug 06, 2019 - 04:06 UTC
Update
GoFileRoom is running slowly. We're sorry for the disruption and our development teams are working to fix this as soon as possible. We'll send an update when we have more information.
Posted about 1 month ago. Aug 06, 2019 - 04:04 UTC
Investigating
We have received reports of slowness in GoFileRoom. We're investigating and monitoring the situation. We'll update the status page and send an update to subscribers as soon as we have more information.
Posted about 1 month ago. Aug 06, 2019 - 03:10 UTC
This incident affected: GoFileRoom.