Error when accessing SurePrep FileRoom

Resolved

Our metrics and internal testing indicate this issue has been resolved and SurePrep FileRoom logins are currently in a healthy state. We are closely monitoring for continued stability.
Posted Jun 30, 2025 - 10:59 EDT

Update

Our technical teams are actively engaged in troubleshooting. We want to assure you that resolving this issue is our highest priority. Please continue to monitor this alert for the latest information. We deeply appreciate your continued patience and understanding.
Posted Jun 30, 2025 - 08:49 EDT

Investigating

Our team is aware of the issue and is urgently working to restore service. Please monitor this alert for updates. Thank you for your patience.
Posted Jun 30, 2025 - 05:59 EDT
This incident affected: SurePrep FileRoom.