Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 24, 2025 - 08:05 EDT
Scheduled
We would like to inform you that the ongoing SurePrep maintenance has extended beyond the initially scheduled time and will now continue until 09:30 AM EDT. We understand this delay may disrupt your workflows, and we sincerely apologize for any inconvenience it may cause. During this period, the SurePrep services are not fully operational. We strongly advise our customers to refrain from using the services until the maintenance is completed. We appreciate your patience and understanding as we work to complete this maintenance safely and restore full functionality. We anticipate having the services available shortly and will provide updates as soon as they are restored.
Posted Aug 24, 2025 - 08:00 EDT
This scheduled maintenance affected: SurePrep FileRoom, SurePrep SPbinder, SurePrep 1040SCAN Review Wizard, and SurePrep API.