Virtual Office CS / SaaS - US - Degraded Performance
Resolved
Email functionality for Virtual Office CS and Saas has been restored to normal operation. The delay in Email delivery has been resolved and the backlog has been processed.

We apologize for the inconvenience.
Posted Jan 01, 2022 - 15:07 EST
Identified
We have received reports of delays in Email within our Virtual Office CS and SaaS environment. We're investigating the situation and will update the status page and send an update to subscribers as soon as we have more information. This is not impacting your standard Virtual Office CS and SaaS applications.
Posted Jan 01, 2022 - 14:14 EST
This incident affected: Virtual Office CS / SaaS.