Virtual Office CS / SaaS - US - Service Disruption
Resolved
We have restored the availability of Virtual Office CS and SaaS applications. We apologize for the inconvenience.
Posted Jan 10, 2022 - 22:39 EST
Update
We are continuing to investigate this issue.
Posted Jan 10, 2022 - 22:27 EST
Investigating
Virtual Office CS and SaaS applications are currently unavailable for all customers. We're sorry for the disruption and our development teams are working to fix this as soon as possible. We'll send an update when we have more information.
Posted Jan 10, 2022 - 22:27 EST
This incident affected: NetClient CS and Virtual Office CS / SaaS.