CS Connect (Electronic Filing) - US - Service Disruption
Resolved
CS Connect (and electronic filing functionality within CS Professional Suite products) is working for all customers.
Posted Aug 04, 2020 - 04:39 UTC
Update
CS Connect (and e-filing in CS Professional Suite products) is currently unavailable for all customers. We're sorry for the disruption and our development teams are working to fix this as soon as possible. We'll send an update when we have more information.
Posted Aug 04, 2020 - 04:30 UTC
Update
CS Connect (and e-filing in CS Professional Suite products) is currently unavailable for all customers. We're sorry for the disruption and our development teams are working to fix this as soon as possible. We'll send an update when we have more information.
Posted Aug 04, 2020 - 04:30 UTC
Update
CS Connect (and e-filing in CS Professional Suite products) is currently unavailable for all customers. We're sorry for the disruption and our development teams are working to fix this as soon as possible. We'll send an update when we have more information.
Posted Aug 04, 2020 - 04:25 UTC
Update
CS Connect (and e-filing in CS Professional Suite products) is currently unavailable for all customers. We're sorry for the disruption and our development teams are working to fix this as soon as possible. We'll send an update when we have more information.
Posted Aug 04, 2020 - 04:17 UTC
Investigating
We have received reports that CS Connect is unavailable. This includes e-filing in CS Professional Suite products. We're investigating and monitoring the situation. We'll update the status page and send an update to subscribers as soon as we have more information.
Posted Aug 04, 2020 - 04:17 UTC
This incident affected: CS Connect/Electronic Filing.