Confirmation - US - Service Disruption
Resolved
Confirmation.com and secure.rivio.com are currently working for all customers.

A significant ISP disruption occurred in the Miami area preventing many users from accessing the application.
Posted Mar 23, 2020 - 10:23 EDT
Investigating
We have received reports that secure.rivio.com powered by Confirmation and confirmation.com are unavailable. We're investigating and monitoring the situation. We'll update the status page and send an update to subscribers as soon as we have more information.
Posted Mar 23, 2020 - 10:02 EDT
This incident affected: Confirmation.com - Rivio.